Scylla Unified Installer

This document covers how to install, uninstall, and upgrade using the Scylla Unified Installer. The Unified Installer is recommended to be used when you do not have root privileges to the server. If you have root privileges, it is recommended to download the OS specific packages (RPMs and DEBs) and install them with the package manager (dnf and apt).

Supported distros

  • CentOS 7 (Only support root offline install)

  • CentOS 8

  • Ubuntu 18.04 (developer-mode is used if NOFILE rlimit is too low)

  • Debian 10

Download and install

For installation without root privileges, follow the instructions on Scylla Download Center

Upgrade / Downgrade/ Uninstall

Upgrade

The unified package is based on a binary package; it’s not a RPM / DEB packages, so it doesn’t upgrade or downgrade by yum / apt. Currently, only install.sh of scylla supports to upgrade.

Root install:

./install.sh --upgrade

Nonroot install

./install.sh --upgrade --nonroot

Note

the installation script does not upgrade scylla-jmx and scylla-tools. You will have to do this separately.

Uninstall

Root uninstall:

sudo ./uninstall.sh

Nonroot uninstall

./uninstall.sh --nonroot

Downgrade

To downgrade to your original Scylla version, use the Uninstall procedure above and then install the original Scylla packages.